07-02-2013, 06:05 PM
User Info
Hello guys,

I have recently (12th of June) bought a whipped dog 24mm silvertip brush. I love everything about it (it is my first silvertip), the loft, the handle, the feel. But I am having a shedding problem, I test lather the brush almost every day and have used it for 4 shaves, every single time the brush shedds two hairs on average. I have read on a shaving blog that this is normal for every brush in the three first months of use, however I am still worried about this issue. Has anyone experienced anything like that (shedding for the first months of use)?

0 65
 07-02-2013, 06:15 PM
  • beartrap
  • Resident Цирюльник
  • Southern California
User Info
Nothing to worry about yet, a couple of hairs is not bad for several uses. Take a comb and give it a good combthrough. If it still sheds contact Larry, I am sure he will take care of it.

88 4,233
 07-02-2013, 08:31 PM
  • blzrfn
  • Butterscotch Bandit
  • Vancouver USA
User Info
My 30mm Whipped Dog has shed several hairs, one or two every time I use it. I haven't used it more than a dozen times though and I am not worried about it. Follow Steve's combing advice and it should settle down. If not, Larry at Whipped Dog seems like a standup guy that stands behind his products.

121 2,252
 07-08-2013, 08:48 PM
  • ben74
  • Administrator
  • Perth, Australia
User Info
A few hairs with the first uses is normal and nothing to be concerned about. If it bothers you, try combing the brush or performing a number of hand lathers.

If clumps of hair are coming away from the knot then that is a problem and would require returning to the manufacturer or vendor.

The odd hair may continue to be shed for months depending on use...

91 17,617
 09-08-2013, 11:46 PM
User Info
The brush hasn't stopped losing hair since I got it so I contacted Larry yesterday and he immediately offer my money back or a new brush without even asking the old brush back. Now that is what I call professionalism!!!

0 65
 09-11-2013, 10:24 AM
User Info
I had the same issue with another customer brush I had made.

After have 2 knots put in it, I gave up. I told SWMBO once I got sick of the shedding (5-10 hairs per use) I'd cut the knot out myself and put something nicer in it.

It's got a 24MM TGN silvertip now.

0 11
 09-11-2013, 12:47 PM
User Info
Geia sou patrida !


I had the same problem with a black badger from WD but only for the first shavings
The real problem was the lack of backbone.

0 353
 09-11-2013, 03:47 PM
User Info
Γειά σου κι εσένα Δορυφέρων!!!!

0 65
 09-11-2013, 04:10 PM
User Info
Good customer support and troubleshooting, Larry does the job very well.

0 135
Users browsing this thread: 1 Guest(s)