04-25-2014, 06:37 AM
#1
User Info
See this photos and videos

[Image: tlt3.jpg]

[Image: 3u44.jpg]



It is normal?

0 179
Reply
 04-25-2014, 06:55 AM
#2
User Info
I am not sure exactly what is wrong with the razor as you don't describe the problem but maybe the knob(shaft) is not screwing into the top plate of the head? If that is the case then something is stripped. Look at the top plate stud if its stripped.

119 13,006
Reply
 04-25-2014, 06:58 AM
#3
  • Lutebro
  • Senior Member
  • Olympia, WA
User Info
I have had one that did that too and I emailed Eric about it. He said if there isn't any play in it then it would create more problems than it would solve by making it tighter. The play is necessary for the flow-through of water when it's used. If you find that the knob pulls out completely what I have done is taken the spacer, the C shaped piece of metal around the knob and stretched it out just a little bit. Then I squeeze it in really tight and it should stay in a lot easier.

58 1,312
Reply
 04-27-2014, 09:55 AM
#4
  • Harvey
  • Senior Member
  • North Hills CA
User Info
One thing to try is holding the top plate downward under spring compression while you tighten the knob....as for the split spring I always remove mine because I like to easily take the knob assembly off to clean and dry the handle....

6 1,994
Reply
 04-27-2014, 10:00 AM
#5
User Info
That looks fine to me. Once it's tight, movement should be there a little. I would widen the c clip and the squeeze it back in so your bottom doesn't fall out.

7 1,182
Reply
 04-27-2014, 10:56 PM
#6
  • CMur12
  • Semogueiro de Coração
  • Moses Lake, Washington State, USA
User Info
José Luís, that is normal for my Mergress, too. Like Dustin said, I assumed that little bit of play in the knob when the top is unscrewed was to allow water an escape from the handle.

- Murray

4 1,150
Reply
 04-28-2014, 12:00 PM
#7
User Info
I've never taken the knob off my Progress. Am I supposed to?

I just loosen it enough to remove the top plate so I can install a new blade, then tighten it up again. Is it necessary to periodically take it apart for cleaning? I hope not.

2 1,387
Reply
 04-28-2014, 12:33 PM
#8
  • CMur12
  • Semogueiro de Coração
  • Moses Lake, Washington State, USA
User Info
Kingfisher, I don't take mine apart, either, and I didn't know it was possible. I do as you do.

- Murray

4 1,150
Reply
 04-28-2014, 03:24 PM
#9
  • Harvey
  • Senior Member
  • North Hills CA
User Info
How you tighten it is the problem....not the razor...try holding top plate downward under spring compression while you tighten knob....go to # 1 and then set it to the setting you prefer.If you want to remove the knob just pull it downward...comes right off...to replace compress split ring and reinstall or remove it all together...serves no purpose.

6 1,994
Reply
 04-29-2014, 07:03 PM
#10
User Info
Mine also has a bit of movement when it is not tightened all the way to #1 where it is has no movement at all. Once I move it to #2 or higher than the movement increases accordingly.

82 21,056
Reply
Users browsing this thread: 1 Guest(s)