05-26-2014, 08:50 PM
#1
User Info
I finally caved and picked one up yesterday. When I got home and brushed my hand against it I saw a few fibers come out. I already shaved so I did a quick hand lather and at least 25 fell out. Tonight I used it to shave and lost even more. All with cool water I must have lost 60-70, maybe more. Is this a defect or has anyone experienced shedding?

4 355
Reply
 05-26-2014, 09:11 PM
#2
User Info
Defect. I've never lost one.

9 197
Reply
 05-26-2014, 09:11 PM
#3
  • PR82
  • Active Member
  • California, US
User Info
(05-26-2014, 08:50 PM)Shakamoto Wrote: I finally caved and picked one up yesterday. When I got home and brushed my hand against it I saw a few fibers come out. I already shaved so I did a quick hand lather and at least 25 fell out. Tonight I used it to shave and lost even more. All with cool water I must have lost 60-70, maybe more. Is this a defect or has anyone experienced shedding?

Sounds like it, mine hasn't shed not one single hair and I've had it a couple of months.

7 298
Reply
 05-26-2014, 09:22 PM
#4
User Info
You likely received a dud brush. You should have no trouble returning it to L'Occitane for an exchange or refund.

0 386
Reply
 05-26-2014, 10:56 PM
#5
User Info
[Image: u3y6uhe7.jpg]

You can see a few more still trying to creep out. I sent an email the other day so I should hear back soon. It's inconvenient to have to go back to the store assuming I can exchange it.

4 355
Reply
 05-27-2014, 07:18 AM
#6
  • Attila
  • The Hungarian Blade
  • Vancouver, Canada
User Info
Definitely a defective brush. This is the first case of shedding for this brush I have heard about. Hopefully you should have no problems exchanging it.

Sent from my phone using Tapatalk.

14 871
Reply
 05-27-2014, 07:42 AM
#7
User Info
(05-26-2014, 09:11 PM)Ronnie Aloha Wrote: Defect. I've never lost one.

+1 Best of luck resolving this issue!

82 21,077
Reply
 05-28-2014, 10:11 AM
#8
User Info
Definitely a defective brush. I would return it as soon as possible.

50 6,053
Reply
 05-28-2014, 12:09 PM
#9
  • Elendil
  • Raggedy man, good night
  • The snow's back.
User Info
That's not good. I'd return it for a new one.

0 1,137
Reply
 05-28-2014, 01:37 PM
#10
User Info
None of my synthetics have shed a single hair from the manufacturer. Definitely defective as has been mentioned. Godspeed in the resolution of this issue. This is the first I've heard of a synthetic shedding this much.

31 8,057
Reply
 05-28-2014, 04:02 PM
#11
  • v4257
  • Always chasing the perfect shave
  • Boston, USA
User Info
(05-27-2014, 07:42 AM)celestino Wrote:
(05-26-2014, 09:11 PM)Ronnie Aloha Wrote: Defect. I've never lost one.

+1 Best of luck resolving this issue!

+2

17 535
Reply
Users browsing this thread: 1 Guest(s)