07-06-2015, 09:06 AM
#1
User Info
Hello Gentlemen !


I was lucky enough to find a Ben Hur Mikron (very much like and Apollo Mikron. The problem is, the adjustable ring doesn't work. There is no resistance when I screw tight, this is just like a regular DE. :/

So, I took it apart, the task was harder than expected because, in the head, some corrosion made some goop and both parts were stuck. So I bathed the razor in several thins, and the head finally came apart.

Here are some pictures :

[Image: img_8910.jpg]

[Image: img_8911.jpg]

[Image: img_8912.jpg]

Isn't it supposed to have a spring somewhere ? My Gibbs adj works with a sprinc, and it's quite easy to see the "adjustment moment" when you close the razor. So :

- does it just miss a spring ?
- is the srping inside but stuck ?
- in the head, in the part aournd the hole, shown here :

[Image: img_8913.jpg]

Is it supposed to be like this ? Because the corrosion hides a lot. Is the center tube supposed to be stuck or should it move ?

Any input is welcome, thank you very much for your attention !

Cheers,
Thomas

3 261
Reply
 07-06-2015, 09:43 AM
#2
User Info
Thomas,
The head should not come apart like yours. It is spring loaded and the cap engages the adjustment mechanism and works against the spring loaded base plate. You might be mechanically be able to fit a spring of some sort between the base plate parts and operate the razor in that condition. But every time you remove the cap the base plate and spring will come apart. Just make sure the spring is wide enough to fit around the hole that allows the cap to mate with the adjustment mechanism. Not perfect but think it would work this way. The razor is broken and missing the spring that holds the head/base plate together and allows the cap to engage the adjustment mechanism under tension. Also make sure the dot on the base plate lines up with the line on the cap. Another point is that the plastic knob with the numbers should be attached to a machined part that inserts into the barrel and screws into the cap. Yours look stuck in the handle. Screw the plastic knob back on and see if you can remove the whole assembly. It operates pretty much like a Merkur Progress and the knob assembly is similar. Razor should be 3 pieces....cap, base plate/head on handle and knob assembly.

54 322
Reply
 07-06-2015, 09:49 AM
#3
User Info
Thomas.
Found a picture showing how the 3 parts look when apart.

[img=1329x998]http://i.imgur.com/fqqhW5u.jpg[/img]
[Image: JpXRQ0a.jpg]

54 322
Reply
 07-06-2015, 11:17 AM
#4
User Info
Thanks you very much, but there is a small screw underneath the red dot, at the end of the handle. A French member told me it would free the metal end part, and reveal the spring inside

3 261
Reply
 07-07-2015, 09:59 AM
#5
User Info
I don't see how that is going to release the spring. The top part of the baseplate has come away from whatever retains it against the part affixed to the handle. You are never going to be able to attach it again. You also need to get the plastic knob assembly removed from the handle then reinserted to make sure it rotates properly and freely when it engages the cap. Look at the three parts above. Then you need to find a spring that has a large enough inside diameter to fit over the two holes in the baseplate and accept the cap to connect with the knob assembly.

54 322
Reply
 07-07-2015, 10:22 AM
#6
User Info
Actually, I was able to reattach the top part to the bottom part, it was just "clicked on", not soldered.

Now I strongly believe that the inside tube, of which we can see the end coming out of the bottom of the baseplate, is supposed to move up and down (along with the top part), but now it's not the case, it's sealed with what I can only describe as corrosion (red arrows) to the handle.

I tried unscrewing the tiny screw at the end of the handle, and it didn't work, the screw is too old and was seriously damaged T_T

I tried putting another spring between both parts of the bease plate but that's when it hit me that the center tube should go upe and down along with the top of the baseplate.

So my hopes are pretty much down at the moment :/

3 261
Reply
Users browsing this thread: 1 Guest(s)