07-20-2015, 06:15 AM
#1
User Info
I have a Fatip Grande nickel plated and a Fatip Grande gold plated. I just discovered something. Most of the time on the nickel one I have to aline the blade to make it even with the cap. I usually just loosen it a little and push the blade counterclockwise a little with a thin piece of cardboard. No big deal. But on my gold one it seems the blade is always perfect. It has to be something in the way they make it at the factory. I guess they need a little more quality control.

[Image: LSUU5mZ.jpg]

5 1,537
Reply
 07-20-2015, 06:20 AM
#2
  • kwsher
  • Senior Member
  • Austin, TX - USA
User Info
I have read similar reports re: blade alignment with Fatip razors.

I have a Fatip Grande in nickle as well that is a treat and zero problems with blade alignment. I would imagine it does revolve around luck of the draw and quality control.

Mine is not one to look at but I sure do love the razor!

2 1,180
Reply
 07-20-2015, 07:01 AM
#3
User Info
I believe it's quite common with the Fatip razors with the top cap being slightly uneven. I have the gold, Anthracite and the nickel plated versions. Like yourself i have slight alignment issues with the nickel version, the blade is a bit more exposed on one side,  not that big of a deal considering it still is an awesome shaver but like Kevin mentioned it really is 'luck of the draw'.

7 786
Reply
 07-20-2015, 07:47 AM
#4
User Info
I used to have one in nickel and it also had issues.

18 713
Reply
Users browsing this thread: 1 Guest(s)