09-15-2015, 08:56 AM
#1
User Info
Scrolling down to the last photo on a page, and scrolling up to the first, the page hangs for a couple seconds before moving again. Been going on for a few weeks. Nothing has changed software- or hardware-wise on my end; latest Firefox, Linux Mint, etc. Cookies and cache cleared. Thoughts?

29 1,776
Reply
 09-15-2015, 03:11 PM
#2
  • leefish
  • Pisciform Cavalry
  • The Netherlands
User Info
Please link to a thread where you see this behaviour

0 822
Reply
 09-15-2015, 03:21 PM
#3
User Info
http://shavenook.com/showthread.php?tid=...#pid592667
This hitch also happens on non-photo heavy pages, trying to scroll to the extreme top of and extreme bottom of page.

29 1,776
Reply
 09-15-2015, 03:21 PM
#4
User Info
You now a Commodore 64 can't handle the scripts from this site, right?











Joking!

61 3,796
Reply
 09-15-2015, 04:06 PM
#5
  • leefish
  • Pisciform Cavalry
  • The Netherlands
User Info
Hm
I just checked on a phone and the page was fine.

Sometimes if there are a lot of images in a thread and you have a lot of posts per page in your settings then loading all the images will cause slowdown.

0 822
Reply
 09-15-2015, 04:08 PM
#6
User Info
Just check on my iPad and it is ok.

61 3,796
Reply
 09-15-2015, 04:12 PM
#7
User Info
It's an annoyance, that's all. It's just that it started happening recently. The hitch comes after the page has loaded completely.

29 1,776
Reply
 09-15-2015, 04:15 PM
#8
  • Johnny
  • MODERATOR EMERITUS
  • Wausau, Wisconsin, USA
User Info
(09-15-2015, 04:06 PM)leefish Wrote: Hm
I just checked on a phone and the page was fine.

Sometimes if there are a lot of images in a thread and you have a lot of posts per page in your settings then loading all the images will cause slowdown.

My desktop is set of where I have 20 post per page on the SOTD section and mine hangs up when trying to scroll down, using the down arrow.  It does not hang when scrolling from bottom to top.  I always figured it was either my old computer or the number of pictures posted.

178 23,808
Reply
 09-16-2015, 02:29 AM
#9
  • leefish
  • Pisciform Cavalry
  • The Netherlands
User Info
@Johnny - its the issues caused by the pictures loading and being resized as they go. Some of the native picture sizes are HUGE, so we have to do this resize. Unfortunately, as the page is still loading when you scroll directly to the bottom then it will "hang" while it finishes loading the images and generally getting the page ready; it cant know how big the images are yet so it is "thinking about it".

@ rsp1202 - How are you triggering the scroll? using the updown arrows that appear at the side?

This post looks like it may be related:  http://forums.linuxmint.com/viewtopic.php?f=90&t=195298 

or this post:  https://www.reddit.com/r/linuxmint/comme...r_related/

I dont know as I dont have that OS available to test.

0 822
Reply
 09-16-2015, 06:02 AM
#10
User Info
Lee, I'm using my mouse's scroll wheel, but it also happens with the up-down arrows. Disabling smooth scrolling doesn't have any effect. I tried Chrome and there was no problem. I'm not ready to switch to Chrome full-time, but Firefox has become more problematic the last few updates.

29 1,776
Reply
 09-16-2015, 02:27 PM
#11
  • leefish
  • Pisciform Cavalry
  • The Netherlands
User Info
Yes, I am hesitant to say "Dont use Firefox" as there is much about it that is good, but as you say there has been an increasing number of issues on last few updates.

0 822
Reply
Users browsing this thread: 1 Guest(s)