12-12-2015, 01:19 PM
#1
User Info
I love my stealth and baby smooth razors,  but recently,  after a long rotation of large number of different razors,  came back to bbs and had 3 shaves.   i found that when i shave with it,  i feel some kind of resistance.

First i thought it was the prep,  thought maybe it was too thick or pasty, but i didnt get lather that was any different from other shaves.

Tried a stealth slant aluminum thinking that if it is the same coating and aluminim material,   it would feel similar,  but stealth remains to glide ever so easily on my face,  no matter what kind of prep.

I am not really complaining about it as its a great shaver,  but wish it didnt have that weird drag or that there is a way to reduce  it.  


Anyone have similar experience?  Found a solution?

53 760
Reply
 12-12-2015, 01:26 PM
#2
User Info
Are you talking about LASS BBS-1 if so, you can send it to me and I will help you evaluate; if it's sub-par I will 'dispose' of it for you free of charge!

If you're saying the baby smooth pulls, try adjusting your angle.  Remember the baby smooth was meant to be super mild for newer shavers and if you're been using more aggressive razors as of late you're angle may be off and the blade may be missing the hairs.

18 654
Reply
 12-12-2015, 01:29 PM
#3
User Info
(12-12-2015, 01:26 PM)GloryUprising Wrote: Are you talking about LASS BBS-1 if so, you can send it to me and I will help you evaluate; if it's sub-par I will 'dispose' of it for you free of charge!

If you're saying the baby smooth pulls, try adjusting your angle.  Remember the baby smooth was meant to be super mild for newer shavers and if you're been using more aggressive razors as of late you're angle may be off and the blade may be missing the hairs.

Razorock baby smooth,  not labbs1(have one,  but no drag issue) 

I was thinking it is either angle or blade, or just a bad combination of whatever. 

Trying to see if anyone has same issue and have found a solution.

53 760
Reply
 12-12-2015, 01:32 PM
#4
User Info
(12-12-2015, 01:29 PM)parachutefactory Wrote:
(12-12-2015, 01:26 PM)GloryUprising Wrote: Are you talking about LASS BBS-1 if so, you can send it to me and I will help you evaluate; if it's sub-par I will 'dispose' of it for you free of charge!

If you're saying the baby smooth pulls, try adjusting your angle.  Remember the baby smooth was meant to be super mild for newer shavers and if you're been using more aggressive razors as of late you're angle may be off and the blade may be missing the hairs.

Razorock baby smooth,  not labbs1(have one,  but no drag issue) 

I was thinking it is either angle or blade, or just a bad combination of whatever. 

Trying to see if anyone has same issue and have found a solution.

When I had a baby smooth, I found that the angle was just so different and newbie friendly but became unintuitive after using more aggressive stuff that I passed it on.

....so yea, try messing with your angles.

18 654
Reply
 12-12-2015, 01:40 PM
#5
User Info
(12-12-2015, 01:32 PM)GloryUprising Wrote:
(12-12-2015, 01:29 PM)parachutefactory Wrote:
(12-12-2015, 01:26 PM)GloryUprising Wrote: Are you talking about LASS BBS-1 if so, you can send it to me and I will help you evaluate; if it's sub-par I will 'dispose' of it for you free of charge!

If you're saying the baby smooth pulls, try adjusting your angle.  Remember the baby smooth was meant to be super mild for newer shavers and if you're been using more aggressive razors as of late you're angle may be off and the blade may be missing the hairs.

Razorock baby smooth,  not labbs1(have one,  but no drag issue) 

I was thinking it is either angle or blade, or just a bad combination of whatever. 

Trying to see if anyone has same issue and have found a solution.

When I had a baby smooth, I found that the angle was just so different and newbie friendly but became unintuitive after using more aggressive stuff that I passed it on.

....so yea, try messing with your angles.

Will do.

53 760
Reply
 12-12-2015, 03:39 PM
#6
User Info
I experience the drag issue as well and haven't found a solution. Well, my solution has been to not use my RRBS. I also have a Merkur 45, which has a VERY similar head profile, but I haven't experienced any of this drag with the Merkur. The drag I experience with the RRBS bothers me enough that I will probably be parting with the razor as soon as I find time to take some photos and post it on eBay.

0 29
Reply
 12-12-2015, 03:49 PM
#7
User Info
(12-12-2015, 03:39 PM)DanCPA Wrote: I experience the drag issue as well and haven't found a solution. Well, my solution has been to not use my RRBS. I also have a Merkur 45, which has a VERY similar head profile, but I haven't experienced any of this drag with the Merkur. The drag I experience with the RRBS bothers me enough that I will probably be parting with the razor as soon as I find time to take some photos and post it on eBay.


I did some google search and did find a thread discussing it.  Don't know if that only represents a minor percentage of people experiencing it or if it's a general consensus that it has some kind of friction issue.
I do find it enough to notice it, but not bad enough to be a deal breaker, so I am trying to see if there's a variable I can change and make it all better.  I guess the first step is to try a different angle.

Then I will try different blades in them eventually and see if aggressiveness/dullness makes any difference.

53 760
Reply
 12-12-2015, 06:01 PM
#8
User Info
i had the same thing. i stripped mine down and made it a brushed finish. i just was not fond of the coating on that one. i had 2 i sold one and kept the brushed one. super easy to do and imo shaves better that way

16 660
Reply
 12-12-2015, 07:14 PM
#9
  • Shanman
  • Reserve Collection Squirrel Hair
  • NE Florida
User Info
Weber DLC and ARC have something similar due to the coating. My DLC has a nice velvety drag that is pleasant for me.

143 1,984
Reply
 12-12-2015, 08:06 PM
#10
User Info
if you end up wanting me to remove the coating id be happy to. ill post some pics of my head for you which as is i said i added a brushed finish to. ill take some pics in the morning

edit here are some pics i posted a while back after brushing the head. the handle is not done here but after this got the same treatment:

[Image: I1Bdn1b.jpg][Image: NsR0qWb.jpg][Image: JicFnrO.jpg][Image: xEzAE8l.jpg]

16 660
Reply
 12-12-2015, 08:42 PM
#11
User Info
(12-12-2015, 07:14 PM)Shanman Wrote: Weber DLC and ARC have something similar due to the coating. My DLC has a nice velvety drag that is pleasant for me.

Jeff, I believe the coating for the DLC is quite unique to any other razor that I have encountered and, fortunately for me, it works extremely well. Biggrin

I can't say that the Baby Smooth 'drags' since I use my Weber DLCs, but the former does not provide very smooth shaves, for me. The few times that I have used it, the shaves have been a bit uncomfortable even using my main blade, Iridium Super.

It, definitely, looks quite different stripped of its black coating!

83 21,081
Reply
 12-13-2015, 05:27 AM
#12
  • Shanman
  • Reserve Collection Squirrel Hair
  • NE Florida
User Info
In terms of drag as I am describing it, I am not speaking of drag in relation to tugging or skipping. It also works very well for me, was curious if the RR drag was being described like the DLC feel.

143 1,984
Reply
 12-13-2015, 06:26 AM
#13
User Info
(12-12-2015, 08:06 PM)mastershake Wrote: if you end up wanting me to remove the coating id be happy to. ill post some pics of my head for you which as is i said i added a brushed finish to. ill take some pics in the morning

edit here are some pics i posted a while back after brushing the head. the handle is not done here but after this got the same treatment:

[Image: I1Bdn1b.jpg][Image: NsR0qWb.jpg][Image: JicFnrO.jpg][Image: xEzAE8l.jpg]

That is actually pretty sweet looking. 
Doable at home or need some kind of machine?

53 760
Reply
 12-13-2015, 06:29 AM
#14
User Info
(12-13-2015, 05:27 AM)Shanman Wrote: In terms of drag as I am describing it, I am not speaking of drag in relation to tugging or skipping. It also works very well for me, was curious if the RR drag was being described like the DLC feel.

You are right,  its not a tug or skip like you get when you use cart razor with thick soap/gel. 

It just feels like it sticks to your face more than usual.  My stealth slants made out of same material with dame coating doesnt have the issue,  so maybe its the head design,  i.e surface area that is touching the face.

53 760
Reply
 12-13-2015, 06:30 AM
#15
User Info
(12-12-2015, 07:14 PM)Shanman Wrote: Weber DLC and ARC have something similar due to the coating. My DLC has a nice velvety drag that is pleasant for me.

Ive tried both dlc and arc,  and i think i know what you are talking about.  It feels very soft/smooth and glides effortlessly. 

This is a different feel unfortunately.

53 760
Reply
 12-13-2015, 05:00 PM
#16
User Info
(12-13-2015, 06:26 AM)parachutefactory Wrote: That is actually pretty sweet looking. 
Doable at home or need some kind of machine?

sent you a pm. but if you decide you want to do it and dont feel you can just let me know.

16 660
Reply
 12-14-2015, 06:45 AM
#17
User Info
(12-13-2015, 05:00 PM)mastershake Wrote:
(12-13-2015, 06:26 AM)parachutefactory Wrote: That is actually pretty sweet looking. 
Doable at home or need some kind of machine?

sent you a pm. but if you decide you want to do it and dont feel you can just let me know.

Will do thanks for the pm.  If no significant change,  i might go ahead and do it.

53 760
Reply
 12-14-2015, 09:26 AM
#18
User Info
imo it made a big difference to me. i much prefer his newest coating to any of the older ones (the one on the black mamba) the baby smooth coating was especially "matte" imo which made it not as smooth (no pun intended)

16 660
Reply
 12-21-2015, 08:25 PM
#19
User Info
Yep, I definitely noticed this "drag" and ended up selling mine. Glad to know it wasn't just me.

25 242
Reply
 12-21-2015, 11:48 PM
#20
User Info
(12-21-2015, 08:25 PM)jpipes3 Wrote: Yep, I definitely noticed this "drag" and ended up selling mine. Glad to know it wasn't just me.
+1

Sent from my SM-T817V using Tapatalk

19 591
Reply
Users browsing this thread: 1 Guest(s)