01-27-2019, 02:58 PM
#1
User Info
I’ve been seeing a problem with pagination on certain threads. E.G., http://shavenook.com/showthread.php?tid=44692 (M&F appreciation thread) shows as having 13 pages, but if you click on page 13, or surf to page 12 then click the next-page link “>>”, you’ll see a “thread doesn’t exist” error (Try this link: http://shavenook.com/showthread.php?tid=44692&page=13). Generally speaking each page shows 20 posts, but on page 12 of the thread above - there are only 17 posts visible to me, and yet there is a “next-page” button. It’s possible that this occurs when certain posts are hidden from view, but are counted when determining pagination.

I generally get this by clicking on “latest” and clicking in the last page of a thread (Like the M&F appreciation thread above). If people keep posting to the thread, eventually it pushes the page count high enough to get pagination working correctly - which makes the problem seem sporadic, but it is predictable. Looks like a bug needs to be logged to the software provider for the forums.


[Image: rzAKgsc.png]

35 1,843
Reply
 01-27-2019, 03:54 PM
#2
  • SCOV
  • Senior Member
  • Minnesota
User Info
Like accurately described above, I have seen the issue 2 times in the last week.  I do not recall the problem before these events.  Software change or bug or ?

Are deleted posts the same as hidden posts ?

16 802
Reply
 01-27-2019, 04:21 PM
#3
  • bullgoose
  • The Enabler
  • Redondo Beach, California, U.S.A
User Info
We have seen this twice in the past week or so. We do not yet know why.

52 20,813
Reply
 01-27-2019, 08:21 PM
#4
User Info
To the best of my knowledge there have been no changes to the software, and hidden/removed posts are - again to the best of my knowledge - stripped out before before the thread is broken into pages, so that shouldn't factor into it.

Clearly there is a glitch in the Matrix...

3 6,428
Reply
 01-27-2019, 10:16 PM
#5
User Info
Users browsing this thread: 1 Guest(s)